YESLY Smart Home

Dieses Thema enthält 51 Antworten und 5 Teilnehmer. Es wurde zuletzt aktualisiert von  bademeister vor 1 Jahr, 7 Monate.

Ansicht von 15 Beiträgen - 16 bis 30 (von insgesamt 52)
  • Autor
    Beiträge
  • #66591
    Hoggle
    Hoggle
    Moderator

    Ich hätte die Funktion und das if dafür mal rausgenommenen, also auskommentieren von Zeile:
    19, 45-48


    Immer hilfreich: Siio-Datenbank
    #66652

    bademeister
    Teilnehmer

    hi hoggle,

    hab ich gemacht.
    der debug schreibt dann folgendes

    [DEBUG] 13:00:07: Tor geöffnet
    [DEBUG] 13:00:22: Tor geschlossen

    ohne dass es Bewegung gegeben hätte…
    es leuchtet noch immer nur grün.

    es sieht so aus, als ob ich an der ersten „if“ abfrage noch ein problem hätte…

    #66654

    bademeister
    Teilnehmer

    und es gibt ne meldung „to many instances“

    #66656
    Hoggle
    Hoggle
    Moderator

    Hast du an dem Motor für das Tor ein Z-Wave-Relais? Und steuerst das Tor damit?


    Immer hilfreich: Siio-Datenbank
    #66658
    Hoggle
    Hoggle
    Moderator

    Ist 0 der Zustand für Kontakt geschlossen? Oben wie unten?


    Immer hilfreich: Siio-Datenbank
    #66667

    bademeister
    Teilnehmer

    ja, ich steuere das tor über ein 1-fach relais.
    0 sollte der zustand für geschlossen sein. bei dem Kontakt oben könnte es aber auch umgekehrt sein, da ich das da umgestellt habe, damit in der ansicht das tor auch offen erscheint, wenn der kontakt geschlossen ist.
    habe das grade mal geändert…

    aber dann passiert gar nichts.

    #66682
    Hoggle
    Hoggle
    Moderator

    Warum lässt Du das Script dann nicht durch das Relais triggern?


    Immer hilfreich: Siio-Datenbank
    #66709

    bademeister
    Teilnehmer

    ginge wohl auch. die lösung hier kam noch von den blockszenen…
    ich probiers mal…

    #66711

    bademeister
    Teilnehmer

    hab mal versucht das Relais als Trigger zu nutzen und hatte den torkontakt oben zustand als geöffnet = 0 gesetzt..

    es hat nichts genützt, ausser das die szene sofort wohl startet und folgender Debug kommt

    [DEBUG] 16:34:16: Tor geöffnet
    [DEBUG] 16:34:31: Tor geschlossen

    obwohl nichts gedrückt wurde. das Tor hat sich nicht bewegt…
    d.h. die szene startet automatisch, ok, und prüft aber schaltet kein licht und kein LED programm…

    #66715
    Hoggle
    Hoggle
    Moderator

    Du hast ja auch im Header den Autostart drin….


    Immer hilfreich: Siio-Datenbank
    #66717

    bademeister
    Teilnehmer

    ich dachte den brauche ich für die funktion der nachtbeleuchtung?
    der letzte code abschnitt…

    #66719
    Hoggle
    Hoggle
    Moderator

    Als nächtrst solltest du dir Beispiele mit einer while-Schleife ansehen.


    Immer hilfreich: Siio-Datenbank
    #66722
    Hoggle
    Hoggle
    Moderator

    Dann solltest du deine Nachtbeleuchtung und das andere trennen.


    Immer hilfreich: Siio-Datenbank
    #66725

    bademeister
    Teilnehmer

    ich dachte das while könnte ich umgehen durch die if abfragen nacheinander…

    #66727
    Hoggle
    Hoggle
    Moderator

    Die Nachtbeleuchtung würde ich dann auch mit der Time of Day (ToD) Variable kombinieren.


    Immer hilfreich: Siio-Datenbank
    • Diese Antwort wurde geändert vor 2 Jahre, 6 Monate von Hoggle Hoggle.
Ansicht von 15 Beiträgen - 16 bis 30 (von insgesamt 52)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.