z-wave-unterputzmodul

Startseite Foren Fibaro Forum (Z-Wave) Fibaro HC2 (Home Center 2) Mesh Konfiguration auslesen

Dieses Thema enthält 105 Antworten und 7 Teilnehmer. Es wurde zuletzt aktualisiert von pblacky pblacky vor 2 Wochen, 1 Tag.

Ansicht von 15 Beiträgen - 91 bis 105 (von insgesamt 106)
  • Autor
    Beiträge
  • #103260
    Ändy
    Ändy
    Teilnehmer

    @pblacky, konntest Du dein Devices damit finden? Hast Du die Anzahl der Hops verringern können?

    Ich hab übrigens einen PHP Server installiert, den ich bei Bedarf über ein kleines Batch-Programm starte und dann die entsprechende HTML-Seite aufrufe. Damit gelingt die Darstellung innerhalb einer Sekunde. Man muss halt sich im Klaren sein, dass man seine Zugangsdaten hinterlegen muss.

    Was mich etwas beschäftigt, ist dass das Datum der Routen seit dem Update unverändert bleibt. Ist das so richtig? Ich dachte immer, das Z-Wave Netz reagiert variabel und gestaltet sich auch alleine um. Andererseits warum sollte man dann eine Mesh Netzwerk Rekonfiguration anstoßen? Kann mir hier jemand auf die Sprünge helfen?


    Grüße, Ändy
    #103262
    Ändy
    Ändy
    Teilnehmer

    @pblacky, konntest Du dein Device damit finden? Hast Du die Anzahl der Hops verringern können?

    Ich hab übrigens einen PHP Server installiert, den ich bei Bedarf über ein kleines Batch-Programm starte und dann die entsprechende HTML Seite aufrufe. Damit gelingt die Darstellung innerhalb einer Sekunde. Man muss halt sich im Klaren sein, dass man seine Zugangsdaten hinterlegen muss.

    Was mich etwas beschäftigt, ist dass das Datum der Routen seit dem Update unverändert bleibt. Ist das so richtig? Ich dachte immer, das Z-Wave Netz reagiert variabel und gestaltet sich auch alleine um. Andererseits warum sollte man dann eine Mesh Netzwerk Rekonfiguration anstoßen? Kann mir hier jemand auf die Sprünge helfen?


    Grüße, Ändy
    #103264
    Ändy
    Ändy
    Teilnehmer

    Sorry wegen Mehrfachposts. Bekam keine Rückmeldung über korrekte Übertragung.


    Grüße, Ändy
    • Diese Antwort wurde geändert vor 1 Monat von Ändy Ändy. Grund: Fehlfunktion
    • Diese Antwort wurde geändert vor 1 Monat von Ändy Ändy.
    #103273

    jeep
    Teilnehmer

    Hi Ändy,

    das habe ich auch schon festgestellt, ist jetzt alles sehr statisch. Vermutlich hat Fibaro nach den vielen Beschwerden den Fehler in die andere Richtung produziert.
    Ich habe gerade bei zwei Geräten eine manuelle reconfig angestoßen. Das hat funktioniert, also die „Last WRRT“ hat sich geändert.
    Leider hat niemand von uns vorher solche Erfahrungen dokumentiert. Aber ich bin schon der Meinung dass es jetzt nach 10 Tagen doch zu statisch ist.


    Grüße, Jeep
    #103275
    pblacky
    pblacky
    Teilnehmer

    Hi @Ändy
    Danke der Nachfrage!
    Habe seit einiger das RoutingInfo.lua (0.1.4) fast täglich im Einsatz und damit folgende Erfahrungen zu berichten:
    Habe vor ca. eine Woche das gesamte Mesh Netzwerk reconfiguriert und dadurch haben sie die HOPS verändert.
    Habe seither KEINE Geräte mit mehr als 3 Hops mehr und nur EIN Gerät mit 3 Hops, das finde ich super!

    Die Devices ohne Nachbarn sind immer noch 43, was mich sehr nachdenklich macht!
    Entweder gibt es da im Skript noch ein Problem, oder ich habe irgendeine Konfiguration übersehen!?
    Würde mal einige weitere Erfahrungen von euch interessieren.
    Hat irgendwer außer mir d“Devices ohne Nachbarn“ mit dem Skript gefunden??

    Auch das „Yet Another lastWorkingRoute visualiser“ funktioniert gut, wie ich es oben beschrieben hab.
    Da bin ich jetzt auf der Suche nach einer Möglichkeit die Grafik aus dem HTML irgendwie abzuspeichern und mir mal mehrere Versionen zu erstellen um Veränderungen sehen zu können!

    #103287
    Ändy
    Ändy
    Teilnehmer

    @pblacky, Windows 7 oder höher? Nimm doch das snipping tool von windows. Oder wenn der Rechner nicht komplett runtergefahren wird einfach die Tabs im Browser stehen lassen.

    Ich glaube nicht dass es am Script liegt. Ich denke eher dass die Information vom HC2 selbst nicht ermittelt werden konnte. Die Daten stehen ja so auch in …/api/devices.

    Vermutlich liest das HC nur bei einer Reconfiguration mit und gelangt so an die Infos. Evtl kann da auch was schief gehen und das Feld oder die Information bleibt leer. Das würde aber auch bedeuten, dass wir, wie schon mal vermutet, nur ein Abbild von irgendwann sehen und den augenblicklichen Stand gar kennen.

    Leider alles nur reine Vermutung.


    Grüße, Ändy
    #103531
    pblacky
    pblacky
    Teilnehmer

    Hi ihr Lieben,
    Hab mich jetzt mal auf die Suche nach einer Erklärung für die „fehlenden Nachbarn“ gemacht.
    Dabei hab ich eine Seite gefunden, wo es ebenfalls Skripte gibt, die das Mesh Netzwerk auslesen.
    https://www.intelligentes-haus.de/tutorials/fibaro-tutorials/fibaro-home-center-2-mesh-netzwerk-analysieren
    Mit dem Skript von dort, habe ich die Devices abgefragt, die mir „ohne Nachbarn“ angezeigt wurden und festgestellt, dass sie DOCH Nachbarn haben!

    Kann nicht beurteilen welche Skripte was genau machen, dazu fehlen mir die LUA Kenntnisse!
    Aber vielleicht hilft es ja jemandem hier ;-)

    #103859
    pblacky
    pblacky
    Teilnehmer

    Mir ist gerade was zu dem „Nachbarn“ Thema eingefallen:

    Ich habe einige Geräte (ca. 5-8 Stück) die ich in der HC2 angelernt, habe, aber derzeit nicht brauche. Diese liegen ohne Batterie in einer Lade!
    Meist sind es Fernbedienungen, Plugs oder Türkontakte.
    Ich habe diese Geräte in der HC2 nicht deaktiviert!
    Kann es sein, dass benachbarte Geräte damit ein Problem haben?

    Werde mal diese Geräte alle deaktivieren und nachsehen, obe sich was ändert!

    #103863
    pblacky
    pblacky
    Teilnehmer

    Habe alle Geräte die nicht verwendet werden auf inaktiv gesetzt und danach das Mesh Netzwerk in der HC2 neu erstellt.
    Trotzden 42 Geräte ohne Nachbarn!
    Das wars also nicht …..

    #103884
    Ändy
    Ändy
    Teilnehmer

    Hi @pblacky
    wenn Du weiterhin auf der Suche bist kannst Du mal prüfen ob es sich um Devices handelt, die die Ids nicht in zusammenhängender Reihenfolge haben. Ich mein da gab es ein Problem. Kannst z.B. mit dem HC Toolkit machen. Da gibt es eine schöne übersichtliche Liste. Weiß nur grad nicht wo und wie.


    Grüße, Ändy
    #103892
    pblacky
    pblacky
    Teilnehmer

    Hi @Ändy,

    Danke für den Tipp, hab ich mir angesehen!
    Geht unter „get Devices“, dann sieht man links die IDs (siehe Screenshot)

    Devices, die keine Nachbarn melden haben in den meisten Fällen sowohl vorher als auch nachher eine direkte ID als Nachbarn.
    Deshalb hab ich in denn Tools mal etwas rumgestöbert und folgendes festgestellt:
    ALLE Devices ohne Nachbarn sind mit der Parent ID „1“ verbunden!! Das ist doch die HC2 (Zentrale) oder?

    Kann es sein dass hier im Skript ein Missverständnis beim Debugging aufgetreten ist?
    Wenn ein Gerät direkt mit der Zentrale verbunden ist, dann BRAUCHT es ja eigentlich keine Nachbarn oder??

    Ich habe ja eigentlich wenig Probleme, außer dass meine Geräte manchmal langsam reagieren wenn ich viele auf einmal abschalte.
    Daher ist meine Suche darauf begründet, dass es bei sonst niemandem als bei mir so viele Gräte ohne Nachbarn gibt.
    Vielleicht ist das ja sogar gut ;-)

    Dateianhänge:
    You must be logged in to view attached files.
    #103899

    jeep
    Teilnehmer

    @pblacky,
    ich bin immer noch ein wenig ratlos, weil es gibt laut Deinem API Auszug nur 15 Geräte ohne Nachbarn und routen. Das sind meist Fernbedienungen, Wandschalter, alte Gen3 Türkontakte, etc. Das kann auch normal sein. Warum aber zum Beispiel der Dimmer mit der ID 36, der 66 NAchbarn hat als Gerät ohne NAchbarn angezeigt wird ist mir noch unklar.
    Erlärung:
    > ALLE Devices ohne Nachbarn sind mit der Parent ID „1“ verbunden!! Das ist doch die HC2 (Zentrale) oder?
    Nein, alle Geräte deren parentID = 1 ist, ist das physikalische Gerät gemeint. Das ist also nicht die Zentrale. Die hat DeviceID = 1 und parentID = 0.

    >Wenn ein Gerät direkt mit der Zentrale verbunden ist, dann BRAUCHT es ja eigentlich keine Nachbarn oder??
    Kann man so nicht sagen, das ist so im Mesh Protokoll vorgesehen das nahe beieinander liegende Geräte auch miteinander kommunizieren können. Fällt ein Nachbar aus Weiß das Gerät über welches andere es die Pakete routen soll. Wenn es die Zentrale auch sieht braucht es keine hops über andere Geräte.

    >Vielleicht ist das ja sogar gut ;-)
    Nein das wäre nicht so gut, es ist aber so dass das Script nur bei Dir 40 Geräte ohne Nachbern anzeigt, aber es in der Relität nur 15 davon gibt.

    Was ich aber noch nicht verstehe, wieso diese Fehlanzeige nur bei Dir auftritt. Da bin ich noch am suchen. Vielleicht kann ich es reproduzieren.
    Danke Dir noch mal für die Bereitstellung der json und jpeg Dateien.


    Grüße, Jeep
    • Diese Antwort wurde geändert vor 2 Wochen, 4 Tagen von  jeep.
    #103907

    jeep
    Teilnehmer

    Hi pblacky,
    habe gerade festgestellt das mir Dein voriger Beitrag entgangen war.
    Wenn Du Geräte includiert lässt und in der Schublade steckst, musst Du auf jedem Fall das Master device disablen. Sonst
    wird es vom HC2 eventuell gepollt. So was kann schon manchmal zu Verzögerungen führen. Außerdem werden diese Geräte dann
    im Script angezeigt und die Werte stimmem dann keineswegs.


    Grüße, Jeep
    #103940
    pblacky
    pblacky
    Teilnehmer

    Danke für den Hinweis @jeep!
    Habe vor 3 Tagen ALLE Geräte in der HC2 deaktiviert, die derzeit nicht eingebaut sind.
    Und zwar sowohl die Haupt IDs als auch ALLE Unter Ids!
    Danach das Mesh Netzwerk der Anlage rekonfiguriert!

    Heute das Skript nochmal laufen lassen und wieder 42 Geräte ohne Nachbarn!
    Die deaktivierten Geräte tauchen in der Liste allerdings NICHT auf!
    Mein Zwave Netzwerk kommt mir jetzt etwas schneller vor, das hat es jedenfalls gebracht ;-)

    Bei der Gelegenheit eine Frage: Was bedeutet der Menüpunkt ÜBER dem Mesh Netzwerk rekonfig ? (siehe Markierung im Anhang)
    Dort steht „Z-Wave zurücksetzen“, was genau passiert nach dem „löschen“ in der Beschreibung.
    Wir das Netzwerk danach wieder aufgebaut, oder ist dann alles WEG?

    Dateianhänge:
    You must be logged in to view attached files.
    #103944

    jeep
    Teilnehmer

    @pblacky,
    >Wir das Netzwerk danach wieder aufgebaut, oder ist dann alles WEG?
    Da ist dann wirklich alles weg. Der zwave Chip bekommt dann eine neue HomeID und keines der Geräte könnte sich mehr mit dem Controller verbinden. Also besser nicht probieren.

    Das mit dem 42 Geräten ohne Nachbarn bereitet mir noch schlaflose Nächte, habe aber noch keine Idee. ;-(


    Grüße, Jeep
Ansicht von 15 Beiträgen - 91 bis 105 (von insgesamt 106)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.