YESLY Smart Home

Startseite Foren Z-Wave Forum Z-Wave Zentralen & Gateways Verhalten des Gateways nach Stromausfall

Dieses Thema enthält 27 Antworten und 11 Teilnehmer. Es wurde zuletzt aktualisiert von  Dr. Bob vor 1 Jahr, 8 Monate.

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 28)
  • Autor
    Beiträge
  • #45254

    boomx
    Teilnehmer

    Nach einem Stromausfall des Gateways kann es dazu kommen, dass das Z-Wave-Netzwerk nicht mehr reagiert, bzw. nur sehr träge funktioniert.

    Durch den Stromausfall und den automatischen Neustart des Gateways kann es dazu kommen, dass alle Module, welche strombetrieben sind, gleichzeitig und mehrmals gepollt werden. Bei einer entsprechenden Anzahl von Geräten kann es hier dann zu einem gefloodeten Z-Wave-Netzwerk kommen, wodurch dann das Netzwerk wie oben beschrieben nicht mehr funktioniert.

    Um dies zu beheben kann wie folgt vorgegangen werden:

    1. Gateway herunterfahren
    2. Module vom Strom nehmen
    3. Gateway starten
    4. Danach die Module wieder einzeln unter Strom setzen

    So kann verhindert werden, das nach dem Neustart sofort das Z-Wave-Netzwerk gefloodet wird.

    #45806

    Daniel_Ri
    Teilnehmer

    Guter Hinweis.
    Am Wochenende hatte ich ein ähnliches Problem, nachdem durch Unwetter der FI rausgesprungen ist hab ich danach Probleme mit dem Schalten meiner Lampen gehabt. Die haben nur sehr träge und widerwillig reagiert.

    @boomx
    Was genau meinst du mit „Module vom Strom nehmen“? Bei Unterputzmodulen hat man dann ja eigentlich nur die Möglichkeit, die Sicherung des Raumes rauszunehmen. Ist das gemeint oder sollte man wirklich ran ans Modul?

    #45808

    TechBen
    Teilnehmer

    Sieht für mich wie ein Designfehler aus …Stromausfälle passieren halt – das muss man doch berücksichtigen.

    #45823

    boomx
    Teilnehmer

    Hi,

    bei UP-Modulen würd ich die Sicherung rausnehmen. Alles andere wäre zu viel Aufwand.

    Ob es ein Designfehler ist, will ich nicht beurteilen. Hab dies so nicht getestet, da es bei mir noch nicht vorgekommen ist. Könnte mir aber vorstellen, dass es zu einem Problem mit dem eingestellten Polling der strombetriebenen Geräte kommt.

    Gruß

    #45959
    Chris
    Chris
    Teilnehmer

    Ok – guter Tipp… Allerdings scheint das GW ODER die App mit 58 Nodes und 16 Szenen „momentan“ an die Grenzen zu stoßen.
    Genau das was du beschreibst ist nach einem Neustart bei mir der Fall…. es geht sehr sehr lange nichts…. Teilweise schaffe ich es dann nichteinmal , dass sich die APP öffnet ( GW synct und synct und synct)

    Der Erweiterte trigger und die UND Verknüpfung – ist prima… allerdings habe ich mehr Probleme , als das es zur Zeit was Smart macht…

    #46625

    jeep
    Teilnehmer

    Also ich behaupte mal das dürfte nicht sein. Wir haben in Deutschland sehr gute Stromnetze aber wie weiter oben angedeutet, es kann schon mal passieren das in zwei Jahren einmal der Strom ausfällt.
    Gateway geordnet herunterfahren und wieder starten ist bestimmt sinnvoll. Von Modulen stromlos und Sicherungen raus machen halte ich nichts. Bis das HC2 gebootet hat haben sich bestimmt alle devices beruhigt und wenn das HC2 jetzt 50 oder 100 devices auf einmal pollen will dann ist das ein Design oder Konfigurationsfehler.
    Ich betreibe meine 52 devices und unzählige Scripte mit FHEM, wollte aber demnächst das HC2 versuchen (nur das meine Frau eine schönere APP bekommt) aber dass muss ich mir jetzt nochmal überlegen…


    Grüße, Jeep
    • Diese Antwort wurde geändert vor 3 Jahre von  jeep.
    #46641

    boomx
    Teilnehmer

    Zitat: „Nach einem Stromausfall des Gateways KANN es dazu kommen, dass das Z-Wave-Netzwerk nicht mehr reagiert, bzw. nur sehr träge funktioniert.“ Ich hatte persönlich damit noch keine Probleme.

    Gruß

    #46670

    jeep
    Teilnehmer

    So denke ich natürlich auch, aber trotzdem bestätigt der Kollege Daniel_Ri ein paar Tage später Deine Vermutungen.


    Grüße, Jeep
    #46725
    mib
    mib
    Teilnehmer

    Ich hatte vor dem Stromausfall von 5 Minuten auch dieses Probelm nicht. Auch nicht wenn ich das HC2 neu starten musste. Allerdings war vorher auch noch nie der Strom zur Gänze im ganze Haus weg.
    Es nützt auch herzlich wenig das HC2 an eine USV zu hängen. Weder kann ich über einen Befehl die Zetrale ordnungsgemäß runterfahren noch macht es Sinn sie weiterlaufen zu lassen. Denn die Module die dann stromlos sind, melden sich wenn der Strom wiederkommt alle auf einmal an und verursachen dann ein flooded Network.
    Bis ca. 50 Module soll es relativ problemlos sein wurde mir gesagt. Über 50 Modulen gibt es angeblich Probleme. Ich habe 103 Module plus Netatmo die auch auf 866 mhz kommunizieren.
    Wäre interessant zu erfahren, ob es eigentlich von Fibaro eine offizielle Obergrenze an Modulen gibt. Also ob irgendwann die Zentrale es nimmer packt oder die Kommunikation gestört ist.

    Und ja, ich halte es für einen nennen wir es mal Designfehler. Oder rechnet Fibaro nicht mit der Verwendung einer größeren Anzahl von Modulen?

    MIB

    • Diese Antwort wurde geändert vor 3 Jahre von mib mib.
    #46747

    jeep
    Teilnehmer

    Nach längerer Überlegung und noch einen Blick in die ZWave-Bibel, glaube ich nicht mehr an einem Designfehler. Wie gesagt das HC2 braucht zum booten ein paar Minuten. Bis es oben ist haben sich alle devices beruhigt. Batteriebetriebene bekommen vom Stromausfall eh nichts mit.
    Ein ZWave device bootet in sekundenschnelle. Wenn es das Bedürfnis hat, was zum Gateway zu schicken da tut es das, wartet auf ein ACK, kommt nichts wiederholt es den Befehl bis zu 2 mal. Außerdem muss es das Duty_Cycle von 1% einhalten. Z.B. 1 ms senden dann 100 ms warten. Das ist die Regel im ZWave Netz.
    Da ich aber kein HC2 habe, kann ich nichts über die poll Häufigkeit sagen. Vermutlich ist das einstellbar. Und ich halte das Gerät für so intelligent dass es nicht alle devices zur gleichen Zeit anpollt. Und wenn doch, dann müsste Fibaro was tun.


    Grüße, Jeep
    #47916
    Andre_Soe
    Andre_Soe
    Teilnehmer

    Sobald alle AKW’s in Deutschland abgeschaltet sind, werden wir sehr wohl mit Stromausfällen kämpfen müssen. Ist aber ein anderes Thema. Gibt es den die Möglichkeit wie z.b. bei einem Server über eine USV den Strom etwas zu halten und dann die HC2 geziehlt runterfahren zu lassen?

    #47927

    boomx
    Teilnehmer

    Ja, dazu gibt es einen LUA-Befehl. Muss ich mal raussuchen.

    Hier wird es eher Probleme mit dem Trigger der Szene geben… Wie kann die Szene automatisch gestartet werden? Über den Stromverbrauch geht es nicht, da die Module ja nicht mehr Reporten und so der letzte Wert drin stehen sollte… Deadnodes abfragen geht eigentlich auch nicht, da es ja mal anderweitig zu Deadnodes kommen kann…

    Eigentlich geht es nur über die USV. Diese muss erkennen, dass kein Strom mehr anliegt und dann die Szene via HC2-API starten. Da ich mich mit dem Thema USV mal gar nicht auskenne: Gibt es USVs,die einen Webhook ausführen können?

    Gruß

    #70832
    Basti
    Basti
    Teilnehmer

    Hi boomx,
    ich habe, seitdem ich gestern etwas unbedacht die Sicherung des Raumes mit dem HC2 rausgenommen hab (zur Installation zweier RollerShutter), das Problem, dass einige Module (sowohl Strom als auch Batterie) als ’nicht konfiguriert‘ angezeigt werden und auch nicht mehr reagieren.
    HC Neustarten hilft nicht. Module vom strom nehmen, hc2 neustarten und die Module nach und nach wieder einstecken hilft auch nicht.
    Hast du noch eine Idee?

    #70834

    jeep
    Teilnehmer

    Hast Du schon eine Softrekonfiguration dieser Module versucht? Wenn das auch nicht hilft, dann kommst Du vermutlich um ex- und inclusion nicht herum.


    Grüße, Jeep
    #70852
    Basti
    Basti
    Teilnehmer

    Funzt bei den einzelnen Modulen nicht. Die hängen ewig (auch nach einen Neustart noch) mit „[Neukonfiguration Im Gange]“ in der Notifications-Liste :-(
    Sollte ich mal das „Alle Modul erneut konfigurieren“ unter Konfiguration: Z-Wave Netzwerk machen?
    Oder direkt ein altes Backup einspielen? :-/

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 28)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.