YESLY Smart Home

Dieses Thema enthält 74 Antworten und 5 Teilnehmer. Es wurde zuletzt aktualisiert von Ändy Ändy vor 1 Monat, 1 Woche.

Ansicht von 15 Beiträgen - 61 bis 75 (von insgesamt 75)
  • Autor
    Beiträge
  • #106535
    thehackisback
    thehackisback
    Teilnehmer

    So da habe ich mir den Code mal angesehen und der Unterschied ist lediglich diese Zeile beim dem MAX: my_sensor.light = lux/4;

    Aber ich scheine wohl meinen Sensor wie auch immer gegrillt zu haben, da mit der Zeile logischerweise meine 2937 Lux nunmehr durch 4 geteilt, also maximal 734 angezeigt werden. Dann werde ich mal einen Ersatzsensor ordern, wenn der Code bei Dir verlässliche Werte anzeigt.

    #106537

    mdietinger
    Teilnehmer

    thehackisback.

    Sorry, habe ich gamz vergessen das ich den LUX Wert künstlich am Arduino verringere, da ich Probleme mit den hohen Werten und der ZWave Übertragung hatte.
    Das der echte Luxwert ist 4* höher als dieser Code auswirft.
    Den Wert habe ich in der HC2 auf W/m2 umgerechnet.
    Bei Sonnenschein habe ich 17.000 (68.000 in echt)

    #106539
    thehackisback
    thehackisback
    Teilnehmer

    Ok, dann lag es zum Glück nicht an meinem Code sondern wohl am Sensor. Ich werde berichten, sobald der neue Sensor da ist. Bis dahin drucke ich mal die Wetterhütte für die Wetterstation weiter. Vielleicht kann ich bis dahin den nächsten Prototyp präsentieren.

    #107432
    thehackisback
    thehackisback
    Teilnehmer

    Abend, so ich habe die letzten Tage mal wieder ein wenig Luft zum Basteln gehabt, dabei habe ich auch den Fehler bezüglich des VEML gefunden. Ich hatte diesen im Setup per I2C angesprochen und danach nur noch im Loop die Werte abgegriffen. Sobald ich aber alles in den Loop verlagere hat dieser die richtigen Werte. Dein Problem mit den hohen Werten hatte ich noch nicht. Könntest du mir noch einen Denkanstoß geben, wie ich den UV-Wert an Wunderground übermittelt bekomme?

    –[[ UV_OUT–]]v2[11]={11,’UV‘,“}

    –[[ UV_OUT–]]v3[WS][11]={‚UV‘,“,“,“}
    `
    Ansonsten habe ich noch ein wenig an den Prototypen der Gehäuse gebastelt. Das blaue ist die zu große Variante als Vogelhaus und die weiße ist die Variante 2, als Wetterhütte mit geringerem Platz innen.
    Bild

    #107465

    mdietinger
    Teilnehmer

    WOW,

    das sieht ja richtig Professionell aus.

    Bezüglich UV Wert solltest bei der Webservice Konfiguration folgendes eingeben. (1. Zeile ist nur Bsp. für Format)

    Nur die Werte in einer unkonfigurierten Zeile ändern.
    Und dann natürlich die Szene einmal starten.
    Hier ist das Wunderground Protokol:
    https://feedback.weather.com/customer/en/portal/articles/2924682-pws-upload-protocol?b_id=17298

    #107477

    mdietinger
    Teilnehmer

    Was hast denn für einen UV Sensor verwendet?

    #107479
    thehackisback
    thehackisback
    Teilnehmer

    Danke für das Lob und den Denkanstoß. Mit dem 3D Programm komme ich deutlich besser klar, als mit Lua. Muss echt mal überlegen, ob ich nicht mal das System gegen z.B. Homey austausche. Der UV Sensor ist ein Veml6070 per i2c. Code kann ich gerne posten, wenn du ihn einsetzen willst.

    #107481

    mdietinger
    Teilnehmer

    Der UV Sensor ist recht günstig, ja bitte teile den Code, wird eh mal Zeit weiterzubasteln.

    #107483
    thehackisback
    thehackisback
    Teilnehmer

    Mach ich am Wochenende. Ich hätte noch ein paar rumliegen, bestelle immer 5 in China. Bei einem ist die Chance des Defektes mir zu groß.

    #107503
    thehackisback
    thehackisback
    Teilnehmer

    Ich habe diesse Libary hier verwendet:
    https://github.com/watterott/VEML6070-Breakout/blob/master/software/VEML6070.ino
    und lediglich den UV-Index hinzugefügt, sodass hieraus folgendes wurde:

    Bis jetzt ist der Wire-Aufruf noch im Setup und funktioniert. Ich wollte aber noch beobachten, ob es nicht wie beim Luxsensor in den Loop wandert.
    Ansonsten habe ich große Probleme mit meiner 0815 Raingauge. Funktioniert deine Davis problemlos? Ich bin am überlegen, ob ich noch einen Regensensor Regensensor verbaue, da ich sonst keine Scene bezüglich der Dachfenster und des Regens bauen kann.

    #107508

    mdietinger
    Teilnehmer

    Danke,

    der Davis Regenmesser funktioniert bis jetzt ohne Probleme.
    Ist halt Riesengroß.
    Falls du Deine Dachfenster bei Regen schließen willst wäre wahrscheinlich ein beheizter Regenmelder besser.
    https://www.reichelt.com/ch/de/regenmelder-hyg-regen-24v-p117274.html?CTYPE=0&MWSTFREE=0&PROVID=2788&wt_gacha=55399629803_272998727678&PROVID=2788&gclid=CjwKCAjw36DpBRAYEiwAmVVDMFHzTGrsOFEJU16U4YGYK6VZ754mpbSK3ou5cC3FBfR3tyGGSIJlgRoCkBEQAvD_BwE&&r=1
    Der sollte beim ersten Tropfen ansprechen und nicht erst nach 0,2mm.
    Kann dir aber nichts zur Zuverlässigkeit sagen.

    #107512
    thehackisback
    thehackisback
    Teilnehmer

    Sieht gut aus, wobei bei allem über 5v beim Arduino/Zuno mein Latein am Ende ist. Da muss ich mich erstmal einlesen, bevor ich den Arduino und den Sensor brate.

    #107514

    mdietinger
    Teilnehmer

    Der Sensor bräuchte eine eigenständige Stromversorgung. Der Arduino käme an den potentialfreien Kontakt. Somit keine Grillgefahr. Wegen Heizung wirds ähnliche Sensoren kaum mit 5V geben.

    #107518
    thehackisback
    thehackisback
    Teilnehmer

    Wie gesagt, ich muss mich da mal einlesen. Habe aktuell z.B. 5V Heizfolien da, die wollte ich kommenden Winter mal in der Regengauge testen. Solche hier z.B. Heizfolie

    #107526
    Ändy
    Ändy
    Teilnehmer

    Danke,

    der Davis Regenmesser funktioniert bis jetzt ohne Probleme.
    Ist halt Riesengroß.
    Falls du Deine Dachfenster bei Regen schließen willst wäre wahrscheinlich ein beheizter Regenmelder besser.
    https://www.reichelt.com/ch/de/regenmelder-hyg-regen-24v-p117274.html?CTYPE=0&MWSTFREE=0&PROVID=2788&wt_gacha=55399629803_272998727678&PROVID=2788&gclid=CjwKCAjw36DpBRAYEiwAmVVDMFHzTGrsOFEJU16U4YGYK6VZ754mpbSK3ou5cC3FBfR3tyGGSIJlgRoCkBEQAvD_BwE&&r=1
    Der sollte beim ersten Tropfen ansprechen und nicht erst nach 0,2mm.
    Kann dir aber nichts zur Zuverlässigkeit sagen.

    Den hab ich seit einem halben Jahr installiert (24V Typ mit UBS). Bisher eher enttäuschend. Zu Anfangs Wackelkontakt am Stecker Sensor-Baugruppe -> Mit Heißkleber fixiert. Festgestellt dass die Heizung recht ordentlich warm ist. Im Winter ok aber bei Nieselregen bleibt tatsächlich der Sensor trocken. Habe jetzt mal die Heizung mittels Jumper ausgestellt. Funktionierte scheinbar besser. Gerade prasselt es wieder runter: Ich schaue ins HC, kein Regen angezeigt :-( Raus und nachschauen… Der Kamm des Sensors ist mit Regentropfen überbrückt. Geht man kurz mit dem Finger drauf, spricht er sofort an. Vermutlich ist der Regen zu sauber. Ich mach jetzt noch einen Versuch mit dem Empfindlichkeitspoti bevor ich mich nach was anderem umschaue.


    Grüße, Ändy
Ansicht von 15 Beiträgen - 61 bis 75 (von insgesamt 75)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.